Rooms Easy Demo Import [Plugin] Not all images importing into Media Library

Viewing 1 reply thread
    • #2894
      Anita
      Participant
      @anita
      Up
      0
      Down
      ::

      I’m having an issue that is driving me crazy! Not all of my images are being imported into the Media Library, most are but not all. To make matters worse, the images in posts/pages aren’t actually any of the images in the media library. Instead, they are imported from the URL of the existing site, and the image URL doesn’t update upon import.

      So, when I did a URL update on the new site that I imported, all of the images disappeared from posts. What am I doing wrong?

    • #2895
      Jerry Simmons
      Participant
      @ferventjerry
      Up
      0
      Down
      ::

      Sounds like there are some inconsistencies between the media library and the post content on the export site. This can happen a few different ways, where the image exists in the file system, but is not in the database for the media library. This can easily happen on a site that has had a database reset, or database imports.

      When that has happened to me, I found it easiest to start with a fresh WP install and rebuild the content. Using Divi’s export/import feature ensures your media library matches your content. You have to work through it page by page, post by post, but if you’re packaging a child theme for sale it is a good idea to have a solid site to export from.

      An alternate option if you just need it to get working fast, you could try using a plugin to import external content, which will check all the image urls in the content, and download them to the media library if they do not exist.

Viewing 1 reply thread
  • You must be logged in to reply to this topic.